MPLS EVPN

MPLS EVPN is slightly different on JunosEvolved as it uses a mac-vrf routing instance rather than an evpn instance. A lot of similarities though and topology and EVE NG import below. 2 Cisco vIOS switches used as CE’s but pick your poison and use whatever you prefer. An OSPF neighbour adjacency has been established between them confirming the EVPN circuit is up.

https://www.juniper.net/documentation/us/en/software/junos/evpn-vxlan/topics/concept/evpns-overview.html

vEVO1

set interfaces et-0/0/0 flexible-vlan-tagging
set interfaces et-0/0/0 encapsulation flexible-ethernet-services
set interfaces et-0/0/0 unit 512 encapsulation vlan-bridge
set interfaces et-0/0/0 unit 512 vlan-id 512
set interfaces et-0/0/0 unit 512 family ethernet-switching
set interfaces et-0/0/2 unit 0 family inet address 1.1.1.1/30
set interfaces et-0/0/2 unit 0 family iso
set interfaces et-0/0/2 unit 0 family mpls
set interfaces irb unit 512 family inet address 10.1.1.254/24
set interfaces irb unit 512 mac 00:ee:22:ee:33:dd
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.5555.5555.00
set interfaces lo0 unit 0 family mpls
set routing-instances cust1 instance-type mac-vrf
set routing-instances cust1 protocols evpn default-gateway do-not-advertise
set routing-instances cust1 service-type vlan-aware
set routing-instances cust1 interface et-0/0/0.512
set routing-instances cust1 route-distinguisher 5.5.5.5:1
set routing-instances cust1 vrf-target target:65530:1
set routing-instances cust1 vlans cust1 vlan-id 512
set routing-instances cust1 vlans cust1 interface et-0/0/0.512
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 5.5.5.5
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int neighbor 6.6.6.6
set protocols isis interface et-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEVO2

set interfaces et-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces et-0/0/0 unit 0 family iso
set interfaces et-0/0/0 unit 0 family mpls
set interfaces et-0/0/1 unit 0 family inet address 2.2.2.1/30
set interfaces et-0/0/1 unit 0 family iso
set interfaces et-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.6666.6666.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 6.6.6.6
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 6.6.6.6
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int cluster 6.6.6.6
set protocols bgp group int neighbor 5.5.5.5
set protocols bgp group int neighbor 33.33.33.33
set protocols isis interface et-0/0/0.0
set protocols isis interface et-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEVO3

set interfaces et-0/0/0 unit 0 family inet address 2.2.2.2/30
set interfaces et-0/0/0 unit 0 family iso
set interfaces et-0/0/0 unit 0 family mpls
set interfaces et-0/0/1 unit 0 family inet address 3.3.3.1/30
set interfaces et-0/0/1 unit 0 family iso
set interfaces et-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 33.33.33.33/32
set interfaces lo0 unit 0 family iso address 49.0000.3333.3333.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 33.33.33.33
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 33.33.33.33
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int cluster 33.33.33.33
set protocols bgp group int neighbor 6.6.6.6
set protocols bgp group int neighbor 7.7.7.7
set protocols isis interface et-0/0/0.0
set protocols isis interface et-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEVO4

set interfaces et-0/0/0 unit 0 family inet address 3.3.3.2/30
set interfaces et-0/0/0 unit 0 family iso
set interfaces et-0/0/0 unit 0 family mpls
set interfaces et-0/0/1 unit 0 family inet address 4.4.4.1/30
set interfaces et-0/0/1 unit 0 family iso
set interfaces et-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.7777.7777.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 7.7.7.7
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 7.7.7.7
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int cluster 7.7.7.7
set protocols bgp group int neighbor 33.33.33.33
set protocols bgp group int neighbor 9.9.9.9
set protocols isis interface et-0/0/0.0
set protocols isis interface et-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEVO5

set interfaces et-0/0/0 flexible-vlan-tagging
set interfaces et-0/0/0 encapsulation flexible-ethernet-services
set interfaces et-0/0/0 unit 512 encapsulation vlan-bridge
set interfaces et-0/0/0 unit 512 vlan-id 512
set interfaces et-0/0/0 unit 512 family ethernet-switching
set interfaces et-0/0/2 unit 0 family inet address 4.4.4.2/30
set interfaces et-0/0/2 unit 0 family iso
set interfaces et-0/0/2 unit 0 family mpls
set interfaces irb unit 512 family inet address 10.1.1.254/24
set interfaces irb unit 512 mac 00:ee:22:ee:33:dd
set interfaces lo0 unit 0 family inet address 9.9.9.9/32
set interfaces lo0 unit 0 family iso address 49.0000.9999.9999.9999.00
set interfaces lo0 unit 0 family mpls
set routing-instances cust1 instance-type mac-vrf
set routing-instances cust1 protocols evpn default-gateway do-not-advertise
set routing-instances cust1 service-type vlan-aware
set routing-instances cust1 interface et-0/0/0.512
set routing-instances cust1 route-distinguisher 9.9.9.9:1
set routing-instances cust1 vrf-target target:65530:1
set routing-instances cust1 vlans cust1 vlan-id 512
set routing-instances cust1 vlans cust1 interface et-0/0/0.512
set routing-options router-id 9.9.9.9
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 9.9.9.9
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int neighbor 7.7.7.7
set protocols isis interface et-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

Your EVPN circuit should now be up and running. Terminal screenshot below showing that OSPF adjacency has been established. You could choose IS-IS, BGP or even EIGRP if using Cisco devices for the CE’s as it’s just a layer 2 circuit between them.

QinQ (802.1Q)

A very simple QinQ topology. 3 vMX devices, 2 Arista vEOS acting as the CE devices (you can use other devices if prefer) and 2vPC’s to confirm IP connectivity. 55 is the C-Tag, 110 the S-Tag

https://www.juniper.net/documentation/us/en/software/junos/multicast-l2/topics/topic-map/q-in-q.html

EVE-NG import file

vMX1

set interfaces ge-0/0/0 unit 0 family bridge interface-mode access
set interfaces ge-0/0/0 unit 0 family bridge vlan-id 110
set interfaces ge-0/0/1 unit 0 family bridge interface-mode trunk
set interfaces ge-0/0/1 unit 0 family bridge vlan-id 110
set bridge-domains customer1 vlan-id 110

vMX2

set interfaces ge-0/0/0 flexible-vlan-tagging
set interfaces ge-0/0/0 encapsulation flexible-ethernet-services
set interfaces ge-0/0/0 unit 0 family bridge interface-mode trunk
set interfaces ge-0/0/0 unit 0 family bridge vlan-id 110
set interfaces ge-0/0/1 flexible-vlan-tagging
set interfaces ge-0/0/1 encapsulation flexible-ethernet-services
set interfaces ge-0/0/1 unit 0 family bridge interface-mode trunk
set interfaces ge-0/0/1 unit 0 family bridge vlan-id 110
set bridge-domains customer1 vlan-id 110

vMX3

set interfaces ge-0/0/0 unit 0 family bridge interface-mode access
set interfaces ge-0/0/0 unit 0 family bridge vlan-id 110
set interfaces ge-0/0/1 unit 0 family bridge interface-mode trunk
set interfaces ge-0/0/1 unit 0 family bridge vlan-id 110
set bridge-domains customer1 vlan-id 110

Configure IP addresses from the same subnet on both of the vPC’s and they should be able to ping each other. The below image of a Wireguard capture shows the double VLAN tags when ping is sent.

L3 VPN & OSPF Sham Link

5 vEX device topology. OSPF Sham link between vEX1 & vEX5 so the VPN backbone is preferred.

https://www.juniper.net/documentation/us/en/software/junos/ospf/topics/topic-map/configuring-ospfv2-sham-links.html

EVE-NG lab import

vEX1

set interfaces ge-0/0/0 unit 0 family inet address 11.11.11.2/30
set interfaces ge-0/0/2 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.5555.5555.00
set interfaces lo0 unit 0 family mpls
set interfaces lo0 unit 1 family inet address 222.222.222.222/32
set interfaces lo0 unit 1 family mpls
set policy-options policy-statement nhs term 1 from protocol bgp
set policy-options policy-statement nhs term 1 then next-hop self
set routing-instances customer1 instance-type vrf
set routing-instances customer1 protocols mpls interface all
set routing-instances customer1 protocols ospf area 0.0.0.0 sham-link-remote 111.111.111.111
set routing-instances customer1 protocols ospf area 0.0.0.0 interface ge-0/0/0.0
set routing-instances customer1 protocols ospf area 0.0.0.0 interface lo0.1
set routing-instances customer1 protocols ospf sham-link local 222.222.222.222
set routing-instances customer1 interface ge-0/0/0.0
set routing-instances customer1 interface lo0.1
set routing-instances customer1 route-distinguisher 5.5.5.5:1
set routing-instances customer1 vrf-target target:65530:1
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 5.5.5.5
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int export nhs
set protocols bgp group int neighbor 6.6.6.6
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface ge-0/0/2.0
set protocols ldp interface lo0.0
set protocols mpls interface all

vEX2

set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.2.2.5/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.6666.6666.00
set interfaces lo0 unit 0 family mpls
set policy-options policy-statement nhs term 1 from protocol bgp
set policy-options policy-statement nhs term 1 then next-hop self
set routing-options router-id 6.6.6.6
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 6.6.6.6
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int export nhs
set protocols bgp group int cluster 6.6.6.6
set protocols bgp group int neighbor 5.5.5.5
set protocols bgp group int neighbor 88.88.88.88
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

Core

set interfaces ge-0/0/0 unit 0 family inet address 2.2.2.6/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 4.4.4.2/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 88.88.88.88/32
set interfaces lo0 unit 0 family iso address 49.0000.8888.8888.0000.00
set interfaces lo0 unit 0 family mpls
set policy-options policy-statement nhs term 1 from protocol bgp
set policy-options policy-statement nhs term 1 then next-hop self
set routing-options router-id 88.88.88.88
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 88.88.88.88
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int export nhs
set protocols bgp group int cluster 88.88.88.88
set protocols bgp group int neighbor 6.6.6.6
set protocols bgp group int neighbor 7.7.7.7
set protocols isis interface all
set protocols ldp interface all
set protocols mpls interface all

vEX4

set interfaces ge-0/0/0 unit 0 family inet address 4.4.4.1/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 3.3.3.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.7777.7777.00
set interfaces lo0 unit 0 family mpls
set policy-options policy-statement nhs term 1 from protocol bgp
set policy-options policy-statement nhs term 1 then next-hop self
set routing-options router-id 7.7.7.7
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 7.7.7.7
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int export nhs
set protocols bgp group int cluster 7.7.7.7
set protocols bgp group int neighbor 8.8.8.8
set protocols bgp group int neighbor 88.88.88.88
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all

vEX5

set interfaces ge-0/0/0 unit 0 family inet address 22.22.22.2/30
set interfaces ge-0/0/2 unit 0 family inet address 3.3.3.2/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 8.8.8.8/32
set interfaces lo0 unit 0 family iso address 49.0000.8888.8888.8888.00
set interfaces lo0 unit 0 family mpls
set interfaces lo0 unit 1 family inet address 111.111.111.111/32
set interfaces lo0 unit 1 family mpls
set policy-options policy-statement nhs term 1 from protocol bgp
set policy-options policy-statement nhs term 1 then next-hop self
set routing-instances customer1 instance-type vrf
set routing-instances customer1 protocols ospf area 0.0.0.0 sham-link-remote 222.222.222.222
set routing-instances customer1 protocols ospf area 0.0.0.0 interface ge-0/0/0.0
set routing-instances customer1 protocols ospf area 0.0.0.0 interface lo0.1
set routing-instances customer1 protocols ospf sham-link local 111.111.111.111
set routing-instances customer1 interface ge-0/0/0.0
set routing-instances customer1 interface lo0.1
set routing-instances customer1 route-distinguisher 8.8.8.8:1
set routing-instances customer1 vrf-target target:65530:1
set routing-options router-id 8.8.8.8
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 8.8.8.8
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int export nhs
set protocols bgp group int neighbor 7.7.7.7
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface ge-0/0/2.0
set protocols ldp interface lo0.0
set protocols mpls interface all

Sham link should now be established. Run ‘show ospf neighbor instance customer1‘ to confirm.

root> show ospf neighbor instance customer1    
Address          Interface              State           ID               Pri  Dead
11.11.11.1       ge-0/0/0.0             Full            12.12.12.1         1    31
111.111.111.111  shamlink.0             Full            111.111.111.111    0    37

MPLS EVPN

Topology of 6 vMX devices with Anycast Gateway and ESI LAG.

EVE-NG lab to import below

vMX1

set interfaces ge-0/0/0 flexible-vlan-tagging
set interfaces ge-0/0/0 encapsulation flexible-ethernet-services
set interfaces ge-0/0/0 unit 512 encapsulation vlan-bridge
set interfaces ge-0/0/0 unit 512 vlan-id 512
set interfaces ge-0/0/0 unit 512 family bridge
set interfaces ge-0/0/2 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces irb unit 512 family inet address 10.1.1.254/24
set interfaces irb unit 512 mac 00:ee:22:ee:33:dd
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.5555.5555.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65530
set protocols mpls interface all
set protocols bgp group int type internal
set protocols bgp group int local-address 5.5.5.5
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int neighbor 6.6.6.6
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface all
set routing-instances cust1 instance-type evpn
set routing-instances cust1 vlan-id 512
set routing-instances cust1 interface ge-0/0/0.512
set routing-instances cust1 routing-interface irb.512
set routing-instances cust1 route-distinguisher 5.5.5.5:1
set routing-instances cust1 vrf-target target:65530:1
set routing-instances cust1 protocols evpn interface ge-0/0/0.512
set routing-instances cust1 protocols evpn default-gateway do-not-advertise

vMX2

set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.2.2.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.6666.6666.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 6.6.6.6
set routing-options autonomous-system 65530
set protocols mpls interface all
set protocols bgp group int type internal
set protocols bgp group int local-address 6.6.6.6
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int cluster 6.6.6.6
set protocols bgp group int neighbor 5.5.5.5
set protocols bgp group int neighbor 33.33.33.33
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all

Core

set interfaces ge-0/0/0 unit 0 family inet address 2.2.2.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 3.3.3.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 33.33.33.33/32
set interfaces lo0 unit 0 family iso address 49.0000.3333.3333.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 33.33.33.33
set routing-options autonomous-system 65530
set protocols mpls interface all
set protocols bgp group int type internal
set protocols bgp group int local-address 33.33.33.33
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int cluster 33.33.33.33
set protocols bgp group int neighbor 6.6.6.6
set protocols bgp group int neighbor 7.7.7.7
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all

vMX4

set interfaces ge-0/0/0 unit 0 family inet address 3.3.3.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 4.4.4.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces ge-0/0/2 unit 0 family inet address 10.10.10.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.7777.7777.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 7.7.7.7
set routing-options autonomous-system 65530
set protocols mpls interface all
set protocols bgp group int type internal
set protocols bgp group int local-address 7.7.7.7
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int cluster 7.7.7.7
set protocols bgp group int neighbor 33.33.33.33
set protocols bgp group int neighbor 8.8.8.8
set protocols bgp group int neighbor 9.9.9.9
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface all

vMX5

set chassis aggregated-devices ethernet device-count 2
set interfaces ge-0/0/0 ether-options 802.3ad ae0
set interfaces ge-0/0/1 ether-options 802.3ad ae1
set interfaces ge-0/0/2 unit 0 family inet address 10.10.10.2/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces ae0 flexible-vlan-tagging
set interfaces ae0 encapsulation flexible-ethernet-services
set interfaces ae0 esi 00:aa:11:bb:22:dd:33:ee:88:ee
set interfaces ae0 esi all-active
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic fast
set interfaces ae0 aggregated-ether-options lacp system-id 00:aa:99:bb:33:dd
set interfaces ae0 unit 512 encapsulation vlan-bridge
set interfaces ae0 unit 512 vlan-id 512
set interfaces ae1 flexible-vlan-tagging
set interfaces ae1 encapsulation flexible-ethernet-services
set interfaces ae1 esi 00:aa:11:bb:22:dd:33:ee:88:ea
set interfaces ae1 esi all-active
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic fast
set interfaces ae1 aggregated-ether-options lacp system-id 00:aa:99:bb:33:db
set interfaces ae1 unit 512 encapsulation vlan-bridge
set interfaces ae1 unit 512 vlan-id 512
set interfaces irb unit 512 family inet address 10.1.1.254/24
set interfaces irb unit 512 mac 00:ee:22:ee:33:dd
set interfaces lo0 unit 0 family inet address 9.9.9.9/32
set interfaces lo0 unit 0 family iso address 49.0000.9999.9999.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 9.9.9.9
set routing-options autonomous-system 65530
set protocols mpls interface all
set protocols bgp group int type internal
set protocols bgp group int local-address 9.9.9.9
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int neighbor 7.7.7.7
set protocols isis interface all
set protocols ldp interface all
set routing-instances cust1 instance-type evpn
set routing-instances cust1 vlan-id 512
set routing-instances cust1 interface ae0.512
set routing-instances cust1 interface ae1.512
set routing-instances cust1 routing-interface irb.512
set routing-instances cust1 route-distinguisher 9.9.9.9:1
set routing-instances cust1 vrf-target target:65530:1
set routing-instances cust1 protocols evpn interface ae0.512
set routing-instances cust1 protocols evpn interface ae1.512
set routing-instances cust1 protocols evpn default-gateway do-not-advertise

vMX6

set chassis aggregated-devices ethernet device-count 2
set interfaces ge-0/0/0 ether-options 802.3ad ae0
set interfaces ge-0/0/1 ether-options 802.3ad ae1
set interfaces ge-0/0/2 unit 0 family inet address 4.4.4.2/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces ae0 flexible-vlan-tagging
set interfaces ae0 encapsulation flexible-ethernet-services
set interfaces ae0 esi 00:aa:11:bb:22:dd:33:ee:88:ee
set interfaces ae0 esi all-active
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic fast
set interfaces ae0 aggregated-ether-options lacp system-id 00:aa:99:bb:33:dd
set interfaces ae0 unit 512 encapsulation vlan-bridge
set interfaces ae0 unit 512 vlan-id 512
set interfaces ae1 flexible-vlan-tagging
set interfaces ae1 encapsulation flexible-ethernet-services
set interfaces ae1 esi 00:aa:11:bb:22:dd:33:ee:88:ea
set interfaces ae1 esi all-active
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic fast
set interfaces ae1 aggregated-ether-options lacp system-id 00:aa:99:bb:33:db
set interfaces ae1 unit 512 encapsulation vlan-bridge
set interfaces ae1 unit 512 vlan-id 512
set interfaces irb unit 512 family inet address 10.1.1.254/24
set interfaces irb unit 512 mac 00:ee:22:ee:33:dd
set interfaces lo0 unit 0 family inet address 8.8.8.8/32
set interfaces lo0 unit 0 family iso address 49.0000.8888.8888.8888.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 8.8.8.8
set routing-options autonomous-system 65530
set protocols mpls interface all
set protocols bgp group int type internal
set protocols bgp group int local-address 8.8.8.8
set protocols bgp group int family inet unicast
set protocols bgp group int family inet-vpn unicast
set protocols bgp group int family evpn signaling
set protocols bgp group int neighbor 7.7.7.7
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface all
set routing-instances cust1 instance-type evpn
set routing-instances cust1 vlan-id 512
set routing-instances cust1 interface ae0.512
set routing-instances cust1 interface ae1.512
set routing-instances cust1 routing-interface irb.512
set routing-instances cust1 route-distinguisher 8.8.8.8:1
set routing-instances cust1 vrf-target target:65530:1
set routing-instances cust1 protocols evpn interface ae0.512
set routing-instances cust1 protocols evpn interface ae1.512
set routing-instances cust1 protocols evpn default-gateway do-not-advertise

You should now have your layer 2 circuit between CE devices. Run ‘show evpn database‘ on either vMX1, vMX5 or vMX6 to confirm you are learning the MAC addresses of your CE devices

root> show evpn database 
Instance: cust1
VLAN  DomainId  MAC address        Active source                  Timestamp        IP address
512             00:ee:22:ee:33:dd  irb.512                        Jan 28 10:02:54  10.1.1.254
512             50:00:00:07:00:00  00:aa:11:bb:22:dd:33:ee:88:ea  Jan 28 10:13:41
512             50:00:00:07:82:00  00:aa:11:bb:22:dd:33:ee:88:ea  Jan 28 10:14:13  10.1.1.75
512             50:00:00:08:82:00  00:aa:11:bb:22:dd:33:ee:88:ee  Jan 28 10:14:12  10.1.1.200
512             50:00:00:09:00:00  ge-0/0/0.512                   Jan 28 10:01:45  10.1.1.2

VPLS

Slightly different topology for this one as multi-homing and a bit of the good old Spanning Tree thrown in. Cisco vIOS routers and switches used for CE devices. EVE-NG import below.

vEX1

set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 encapsulation vlan-vpls
set interfaces ge-0/0/0 unit 512 encapsulation vlan-vpls
set interfaces ge-0/0/0 unit 512 vlan-id 512
set interfaces ge-0/0/0 unit 512 family vpls
set interfaces ge-0/0/2 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.5555.5555.00
set interfaces lo0 unit 0 family mpls
set routing-instances cust1 instance-type vpls
set routing-instances cust1 protocols vpls site cust1-1 interface ge-0/0/0.512
set routing-instances cust1 protocols vpls site cust1-1 site-identifier 1
set routing-instances cust1 protocols vpls site-range 1000
set routing-instances cust1 interface ge-0/0/0.512
set routing-instances cust1 route-distinguisher 5.5.5.5:1
set routing-instances cust1 vrf-target target:65530:1
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65530
set protocols bgp path-selection l2vpn-use-bgp-rules
set protocols bgp group int type internal
set protocols bgp group int local-address 5.5.5.5
set protocols bgp group int family inet unicast
set protocols bgp group int family l2vpn signaling
set protocols bgp group int neighbor 8.8.8.8
set protocols bgp group int neighbor 9.9.9.9
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEX2

set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.2.2.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.6666.6666.00
set interfaces lo0 unit 0 family mpls
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

Core

set interfaces ge-0/0/0 unit 0 family inet address 2.2.2.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 3.3.3.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 33.33.33.33/32
set interfaces lo0 unit 0 family iso address 49.0000.3333.3333.0000.00
set interfaces lo0 unit 0 family mpls
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEX4

set interfaces ge-0/0/0 unit 0 family inet address 3.3.3.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 4.4.4.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces ge-0/0/2 unit 0 family inet address 10.10.10.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.7777.7777.00
set interfaces lo0 unit 0 family mpls
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEX5

set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 encapsulation vlan-vpls
set interfaces ge-0/0/0 unit 512 encapsulation vlan-vpls
set interfaces ge-0/0/0 unit 512 vlan-id 512
set interfaces ge-0/0/0 unit 512 family vpls
set interfaces ge-0/0/1 vlan-tagging
set interfaces ge-0/0/1 encapsulation vlan-vpls
set interfaces ge-0/0/1 unit 512 encapsulation vlan-vpls
set interfaces ge-0/0/1 unit 512 vlan-id 512
set interfaces ge-0/0/2 unit 0 family inet address 4.4.4.2/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces ge-0/0/3 vlan-tagging
set interfaces ge-0/0/3 encapsulation vlan-vpls
set interfaces ge-0/0/3 unit 512 encapsulation vlan-vpls
set interfaces ge-0/0/3 unit 512 vlan-id 512
set interfaces lo0 unit 0 family inet address 8.8.8.8/32
set interfaces lo0 unit 0 family iso address 49.0000.8888.8888.8888.00
set interfaces lo0 unit 0 family mpls
set routing-instances cust1 instance-type vpls
set routing-instances cust1 protocols vpls site cust1-2 interface ge-0/0/0.512
set routing-instances cust1 protocols vpls site cust1-2 interface ge-0/0/1.512
set routing-instances cust1 protocols vpls site cust1-2 interface ge-0/0/3.512
set routing-instances cust1 protocols vpls site cust1-2 site-identifier 2
set routing-instances cust1 protocols vpls site cust1-2 multi-homing
set routing-instances cust1 protocols vpls site cust1-2 site-preference 255
set routing-instances cust1 protocols vpls site-range 1000
set routing-instances cust1 interface ge-0/0/0.512
set routing-instances cust1 interface ge-0/0/1.512
set routing-instances cust1 interface ge-0/0/3.512
set routing-instances cust1 route-distinguisher 8.8.8.8:1
set routing-instances cust1 vrf-target target:65530:1
set routing-instances cust1-stp instance-type layer2-control
set routing-instances cust1-stp protocols mstp configuration-name cust1
set routing-instances cust1-stp protocols mstp revision-level 1
set routing-instances cust1-stp protocols mstp interface ge-0/0/1
set routing-instances cust1-stp protocols mstp interface ge-0/0/3
set routing-instances cust1-stp protocols mstp msti 1 vlan 512
set routing-instances cust1-stp interface ge-0/0/1.512
set routing-instances cust1-stp interface ge-0/0/3.512
set routing-options router-id 8.8.8.8
set routing-options autonomous-system 65530
set protocols bgp path-selection l2vpn-use-bgp-rules
set protocols bgp group int type internal
set protocols bgp group int local-address 8.8.8.8
set protocols bgp group int family inet unicast
set protocols bgp group int family l2vpn signaling
set protocols bgp group int neighbor 5.5.5.5
set protocols bgp group int neighbor 9.9.9.9
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEX6

set interfaces ge-0/0/0 unit 0 family inet address 10.10.10.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 vlan-tagging
set interfaces ge-0/0/1 encapsulation vlan-vpls
set interfaces ge-0/0/1 unit 512 encapsulation vlan-vpls
set interfaces ge-0/0/1 unit 512 vlan-id 512
set interfaces lo0 unit 0 family inet address 9.9.9.9/32
set interfaces lo0 unit 0 family iso address 49.0000.9999.9999.9990.00
set interfaces lo0 unit 0 family mpls
set routing-instances cust1 instance-type vpls
set routing-instances cust1 protocols vpls site cust1-2 interface ge-0/0/1.512
set routing-instances cust1 protocols vpls site cust1-2 site-identifier 2
set routing-instances cust1 protocols vpls site cust1-2 multi-homing
set routing-instances cust1 protocols vpls site cust1-2 site-preference 255
set routing-instances cust1 protocols vpls site-range 1000
set routing-instances cust1 interface ge-0/0/1.512
set routing-instances cust1 route-distinguisher 8.8.8.8:1
set routing-instances cust1 vrf-target target:65530:1
set routing-instances cust1-stp instance-type layer2-control
set routing-instances cust1-stp protocols mstp configuration-name cust1
set routing-instances cust1-stp protocols mstp revision-level 1
set routing-instances cust1-stp protocols mstp interface ge-0/0/1
set routing-instances cust1-stp interface ge-0/0/1.512
set routing-options router-id 9.9.9.9
set routing-options autonomous-system 65530
set protocols bgp path-selection l2vpn-use-bgp-rules
set protocols bgp group int type internal
set protocols bgp group int local-address 9.9.9.9
set protocols bgp group int family inet unicast
set protocols bgp group int family l2vpn signaling
set protocols bgp group int neighbor 5.5.5.5
set protocols isis interface all
set protocols ldp interface all
set protocols mpls interface all

Run ‘show vpls connections‘ on vEX1, vEX5 or vEX6 to confirm all is up and running

root> show vpls connections 
Layer-2 VPN connections:

Legend for connection status (St)   
EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch     WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
CM -- control-word mismatch      -> -- only outbound connection is up
CN -- circuit not provisioned    <- -- only inbound connection is up
OR -- out of range               Up -- operational
OL -- no outgoing label          Dn -- down                      
LD -- local site signaled down   CF -- call admission control failure      
RD -- remote site signaled down  SC -- local and remote site ID collision
LN -- local site not designated  LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status  IL -- no incoming label
MM -- MTU mismatch               MI -- Mesh-Group ID not available
BK -- Backup connection          ST -- Standby connection
PF -- Profile parse failure      PB -- Profile busy
RS -- remote site standby        SN -- Static Neighbor
LB -- Local site not best-site   RB -- Remote site not best-site
VM -- VLAN ID mismatch           HS -- Hot-standby Connection

Legend for interface status 
Up -- operational                       
Dn -- down

Instance: cust1
Edge protection: Not-Primary
  Local site: cust1-2 (2)
    connection-site           Type  St     Time last up          # Up trans
    1                         rmt   LB   
    999                       rmt   LB   
  Local site: dummy (998)
    connection-site           Type  St     Time last up          # Up trans
    1                         rmt   RB   
    999                       rmt   Up     Jan 27 17:22:08 2024           1
      Remote PE: 5.5.5.5, Negotiated control-word: No
      Incoming label: 800014, Outgoing label: 800013
      Local interface: vt-0/0/0.1048576, Status: Up, Encapsulation: VPLS
        Description: Intf - vpls cust1 local site 998 remote site 999
      Flow Label Transmit: No, Flow Label Receive: No

LDP L2VPN

This uses the same topology as the BGP L2VPN and again, IS-IS is the IGP.

EVE-NG import is below

vEX1

set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 encapsulation flexible-ethernet-services
set interfaces ge-0/0/0 unit 512 encapsulation vlan-ccc
set interfaces ge-0/0/0 unit 512 vlan-id 512
set interfaces ge-0/0/2 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.5555.5555.00
set interfaces lo0 unit 0 family mpls
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols l2circuit neighbor 8.8.8.8 interface ge-0/0/0.512 virtual-circuit-id 3
set protocols ldp interface all
set protocols mpls interface all

vEX2

set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.2.2.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family iso address 49.0000.6666.6666.6666.00
set interfaces lo0 unit 0 family mpls
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

Core

set interfaces ge-0/0/0 unit 0 family inet address 2.2.2.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 3.3.3.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 33.33.33.33/32
set interfaces lo0 unit 0 family iso address 49.0000.3333.3333.0000.00
set interfaces lo0 unit 0 family mpls
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEX4

set interfaces ge-0/0/0 unit 0 family inet address 3.3.3.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 4.4.4.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.7777.7777.00
set interfaces lo0 unit 0 family mpls
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEX5

set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 encapsulation flexible-ethernet-services
set interfaces ge-0/0/0 unit 512 encapsulation vlan-ccc
set interfaces ge-0/0/0 unit 512 vlan-id 512
set interfaces ge-0/0/2 unit 0 family inet address 4.4.4.2/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 8.8.8.8/32
set interfaces lo0 unit 0 family iso address 49.0000.8888.8888.8888.00
set interfaces lo0 unit 0 family mpls
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols l2circuit neighbor 5.5.5.5 interface ge-0/0/0.512 virtual-circuit-id 3
set protocols ldp interface all
set protocols mpls interface all

Now run ‘show l2circuit connections‘ on vEX1 or vEX5 to confirm the circuit is up

root> show l2circuit connections 
Layer-2 Circuit Connections:

Legend for connection status (St)   
EI -- encapsulation invalid      NP -- interface h/w not present   
MM -- mtu mismatch               Dn -- down                       
EM -- encapsulation mismatch     VC-Dn -- Virtual circuit Down    
CM -- control-word mismatch      Up -- operational                
VM -- vlan id mismatch           CF -- Call admission control failure
OL -- no outgoing label          IB -- TDM incompatible bitrate 
NC -- intf encaps not CCC/TCC    TM -- TDM misconfiguration 
BK -- Backup Connection          ST -- Standby Connection
CB -- rcvd cell-bundle size bad  SP -- Static Pseudowire
LD -- local site signaled down   RS -- remote site standby
RD -- remote site signaled down  HS -- Hot-standby Connection
XX -- unknown

Legend for interface status  
Up -- operational            
Dn -- down                   
Neighbor: 8.8.8.8 
    Interface                 Type  St     Time last up          # Up trans
    ge-0/0/0.512(vc 3)        rmt   Up     Jan 27 16:56:49 2024           1
      Remote PE: 8.8.8.8, Negotiated control-word: Yes (Null)
      Incoming label: 299776, Outgoing label: 299776
      Negotiated PW status TLV: No
      Local interface: ge-0/0/0.512, Status: Up, Encapsulation: VLAN
      Flow Label Transmit: No, Flow Label Receive: No

BGP L2VPN

Our first lab and to start we will go with a pretty straightforward BGP L2VPN.

The topology is 5 vEX devices. vEX2, Core & vEX4 act as route reflectors and IS-IS the IGP. Cisco vIOS routers are chosen as CE devices as they are pretty lightweight to run but you can change to the CE of your choice.

If using EVE-NG you can import the lab using the below file

Now for the commands!

vEX1

set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 encapsulation flexible-ethernet-services
set interfaces ge-0/0/0 unit 512 encapsulation vlan-ccc
set interfaces ge-0/0/0 unit 512 vlan-id 512
set interfaces ge-0/0/2 unit 0 family inet address 1.1.1.1/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 5.5.5.5/32
set interfaces lo0 unit 0 family iso address 49.0000.5555.5555.5555.00
set interfaces lo0 unit 0 family mpls
set routing-instances cust1 instance-type l2vpn
set routing-instances cust1 protocols l2vpn site cust1 interface ge-0/0/0.512
set routing-instances cust1 protocols l2vpn site cust1 site-identifier 1
set routing-instances cust1 protocols l2vpn encapsulation-type ethernet-vlan
set routing-instances cust1 interface ge-0/0/0.512
set routing-instances cust1 route-distinguisher 5.5.5.5:1
set routing-instances cust1 vrf-target target:65530:1
set routing-options router-id 5.5.5.5
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 5.5.5.5
set protocols bgp group int family inet unicast
set protocols bgp group int family l2vpn signaling
set protocols bgp group int neighbor 6.6.6.6
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface ge-0/0/2.0
set protocols ldp interface lo0.0
set protocols mpls interface all

vEX2

set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 2.2.2.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 6.6.6.6/32
set interfaces lo0 unit 0 family mpls
set interfaces lo0 unit 0 family iso address 49.0000.6666.6666.6666.00
set routing-options router-id 6.6.6.6
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 6.6.6.6
set protocols bgp group int cluster 6.6.6.6
set protocols bgp group int family inet unicast
set protocols bgp group int family l2vpn signaling
set protocols bgp group int neighbor 5.5.5.5
set protocols bgp group int neighbor 33.33.33.33
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

Core

set interfaces ge-0/0/0 unit 0 family inet address 2.2.2.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 3.3.3.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 33.33.33.33/32
set interfaces lo0 unit 0 family iso address 49.0000.3333.3333.0000.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 33.33.33.33
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 33.33.33.33
set protocols bgp group int family inet unicast
set protocols bgp group int family l2vpn signaling
set protocols bgp group int cluster 33.33.33.33
set protocols bgp group int neighbor 6.6.6.6
set protocols bgp group int neighbor 7.7.7.7
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEX4

set interfaces ge-0/0/0 unit 0 family inet address 3.3.3.2/30
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 4.4.4.1/30
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 7.7.7.7/32
set interfaces lo0 unit 0 family iso address 49.0000.7777.7777.7777.00
set interfaces lo0 unit 0 family mpls
set routing-options router-id 7.7.7.7
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 7.7.7.7
set protocols bgp group int family inet unicast
set protocols bgp group int family l2vpn signaling
set protocols bgp group int cluster 7.7.7.7
set protocols bgp group int neighbor 8.8.8.8
set protocols bgp group int neighbor 33.33.33.33
set protocols isis interface ge-0/0/0.0
set protocols isis interface ge-0/0/1.0
set protocols isis interface lo0.0
set protocols ldp interface all
set protocols mpls interface all

vEX5

set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 encapsulation flexible-ethernet-services
set interfaces ge-0/0/0 unit 512 encapsulation vlan-ccc
set interfaces ge-0/0/0 unit 512 vlan-id 512
set interfaces ge-0/0/2 unit 0 family inet address 4.4.4.2/30
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 8.8.8.8/32
set interfaces lo0 unit 0 family iso address 49.0000.8888.8888.8888.00
set interfaces lo0 unit 0 family mpls
set routing-instances cust1 instance-type l2vpn
set routing-instances cust1 protocols l2vpn site cust1 interface ge-0/0/0.512
set routing-instances cust1 protocols l2vpn site cust1 site-identifier 2
set routing-instances cust1 protocols l2vpn encapsulation-type ethernet-vlan
set routing-instances cust1 interface ge-0/0/0.512
set routing-instances cust1 route-distinguisher 8.8.8.8:1
set routing-instances cust1 vrf-target target:65530:1
set routing-options router-id 8.8.8.8
set routing-options autonomous-system 65530
set protocols bgp group int type internal
set protocols bgp group int local-address 8.8.8.8
set protocols bgp group int family inet unicast
set protocols bgp group int family l2vpn signaling
set protocols bgp group int neighbor 7.7.7.7
set protocols isis interface ge-0/0/2.0
set protocols isis interface lo0.0
set protocols ldp interface ge-0/0/2.0
set protocols ldp interface lo0.0
set protocols mpls interface all

Once all commands have been applied, run ‘show l2vpn connections‘ on vEX1 or vEX5 to confirm all is good. Example of output is below.

root> show l2vpn connections    
Layer-2 VPN connections:

Legend for connection status (St)   
EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch     WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
CM -- control-word mismatch      -> -- only outbound connection is up
CN -- circuit not provisioned    <- -- only inbound connection is up
OR -- out of range               Up -- operational
OL -- no outgoing label          Dn -- down                      
LD -- local site signaled down   CF -- call admission control failure      
RD -- remote site signaled down  SC -- local and remote site ID collision
LN -- local site not designated  LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status  IL -- no incoming label
MM -- MTU mismatch               MI -- Mesh-Group ID not available
BK -- Backup connection          ST -- Standby connection
PF -- Profile parse failure      PB -- Profile busy
RS -- remote site standby        SN -- Static Neighbor
LB -- Local site not best-site   RB -- Remote site not best-site
VM -- VLAN ID mismatch           HS -- Hot-standby Connection

Legend for interface status 
Up -- operational                       
Dn -- down

Instance: cust1
Edge protection: Not-Primary
  Local site: cust1 (1)
    connection-site           Type  St     Time last up          # Up trans
    2                         rmt   Up     Jan 27 12:29:12 2024           1
      Remote PE: 8.8.8.8, Negotiated control-word: Yes (Null)
      Incoming label: 800001, Outgoing label: 800000
      Local interface: ge-0/0/0.512, Status: Up, Encapsulation: VLAN
      Flow Label Transmit: No, Flow Label Receive: No

Welcome

Welcome to JNCIP-SP.

Here you will find a range of virtual labs for use on both EVE-NG & GNS3 to help with your certification studies. All the labs are provided free of charge and include all the commands to get the lab up and running. Also, lab templates will be provided for EVE-NG for you to import. If you are looking for labs from other vendors then please check lab-it-up.com.

The labs are all based on 3 different Junos virtual images. vJunos-switch & vJunosEvolved are free to download from Juniper’s website. vMX is now end of life and no longer available to download but sure some of you still have to image to use.

More labs will be added in due course so please check the site regularly for updates. In the meantime, happy labbing and good luck with your studies!